Comments you submit will be routed for moderation. If you have an account, please log in first.

Ticket #74 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 12 days ago

Develop test driver base class that manages execution IO

Reported by: wehart Owned by: wehart
Priority: normal Milestone: PyUtilib 5.x
Component: pyutilib.autotest Version:
Keywords: Cc:


The default behavior in pyutilib.autotest is to call a test driver without worrying what exactly the testdriver does.

In practice, this capability is likely to be used primarily for the execution of external scripts. Consequently, it makes sense to provide a test driver plugin that provides hooks for managing I/O in a standardized manner.

Several other tickets implicitly require this mechanism. This ticket documents the need to develop this generic testdriver.


Change History

comment:1 Changed 12 days ago by wehart

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of github repos


Add a comment

Modify Ticket

Change Properties
<Author field>
as closed
The resolution will be deleted. Next status will be 'reopened'

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.