Ticket #4167 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Ubuntu 12 Trilinos package build error

Reported by: alex.swindler@… Owned by: briadam
Priority: normal Milestone:
Component: Code Errors/Issues Version: 5.2
Severity: normal Keywords:
Cc: Due Date:
Parent Tickets: Blocked By:
Blocking: Requestor:
Sensitive: no

Description

After switching to Ubuntu 12 from Ubuntu 10 I received a build error while attempting to build Dakota, specifically the teuchos target. I'm not sure if this has been fixed in a later version of Trilinos, but it's present in Dakota 5.2.

After including stddef.h in Teuchos_ConfigDefs.hpp, it built properly.

$ make
Scanning dependencies of target teuchos
[ 0%] Building CXX object packages/teuchos/src/CMakeFiles/teuchos.dir/Teuchos_BLAS.cpp.o
In file included from /home/bldadmin/Dakota/packages/teuchos/src/Teuchos_BLAS.hpp:73:0,

from /home/bldadmin/Dakota/packages/teuchos/src/Teuchos_BLAS.cpp:29:

/home/bldadmin/Dakota/packages/teuchos/src/Teuchos_ConfigDefs.hpp:129:9: error: ‘ptrdiff_t’ does not name a type
/home/bldadmin/Dakota/packages/teuchos/src/Teuchos_ConfigDefs.hpp:132:29: error: ‘Teuchos_Ordinal’ does not name a type
/home/bldadmin/Dakota/packages/teuchos/src/Teuchos_ConfigDefs.hpp:136:9: error: ‘Teuchos_Ordinal’ does not name a type
make[2]: * [packages/teuchos/src/CMakeFiles/teuchos.dir/Teuchos_BLAS.cpp.o] Error 1
make[1]:
* [packages/teuchos/src/CMakeFiles/teuchos.dir/all] Error 2
make: * [all] Error 2

Subtickets

Change History

comment:1 in reply to: ↑ description Changed 6 years ago by wjbohnh

  • Status changed from new to closed
  • Resolution set to fixed

Replying to alex.swindler@…:

... present in Dakota 5.2.

After including stddef.h in Teuchos_ConfigDefs.hpp, it built properly.

Sorry for your trouble. That issue has been fixed, but AFTER the DAKOTA 5.2 release:

 https://software.sandia.gov/viewvc/tpl/teuchos/tags/10.6.0/src/Teuchos_ConfigDefs.hpp?r1=2633&r2=2632&pathrev=2633

Applying that patch (i.e. #include <cstddef> near the top of Teuchos_ConfigDefs.hpp), and re-building would probably be the easiest thing for you to do. Alternatively, you could download the latest stable release and try again. Good luck.

This is a duplicate of #4148

Note: See TracTickets for help on using tickets.