Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Ticket #4030 (closed defect: invalid)

Opened 6 years ago

Last modified 5 years ago

Parameter/Option management

Reported by: wehart Owned by: wehart
Priority: major Milestone: 4.0
Component: Source Code Version: 3.3
Keywords: Cc:

Description (last modified by wehart) (diff)

For some time we've known that there is a limitation of the existing parameter management: if you have an option line like

command --foo bar

then the option parser will assume that bar is the value of the foo option, even if the foo option is boolean.

While setting up the OptionParser? object, it became clear that the reason for this limitation is that (a) the ParameterList? object is used to parse the command-line, but (b) ParameterList? doesn't know the types of the options.

This points to a fundamental design flaw of the ParameterSet/ParameterList? class structure. This needs to be reworked before the next major UTILIB release!!!

Attachments

Change History

comment:1 Changed 6 years ago by wehart

  • Description modified (diff)
  • Milestone set to 4.0

I think this has been resolved, but that needs to be confirmed in our unit tests.

comment:2 Changed 6 years ago by wehart

  • Version changed from 3.0 to 3.3

comment:3 Changed 6 years ago by jdsiiro

  • Priority changed from high to major
  • severity major deleted

Converting all severities into priorities and deprecating the severity field.

comment:4 Changed 5 years ago by wehart

  • Status changed from new to closed
  • Resolution set to invalid

This is ticket is superceded by #4064, which describes why replacing ParameterList? is not so easy. :(

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.