Ticket #4321 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

Memory Leak in Pyomo

Reported by: maxsax74@… Owned by: unassigned
Priority: major Milestone: Coopr 3.4
Component: pyomo.core Version:
Keywords: pyomo memory leak Cc:

Description

Solving multiple time same AbstractProblem , memory grow indefinitely.

My analisys is based on simple code attached using an object profiler (objgraph.py); I attach also results of test on my machine (WinXP 32 bit + Python 2.7.2 + Coopr trunk 3.1.5454)

Leonardo

Attachments

src.zip Download (5.3 KB) - added by anonymous 6 years ago.

Change History

Changed 6 years ago by anonymous

comment:1 Changed 6 years ago by jdsiiro

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4320

comment:2 Changed 4 years ago by wehart

  • Milestone changed from Coopr 3.x to Coopr 3.4
Note: See TracTickets for help on using tickets.