Ticket #4113 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

new badrank needs qthreading and XMT profiling

Reported by: jberry Owned by: gemacke
Priority: normal Milestone: 1.2
Version: 1.1.1 Severity: normal
Keywords: badrank qthreads Kolda Procopio Cc:

Description

The version of badrank in svn3740 now works in serial according to
the paper "Generalized BadRank? with Graduated Trust" by Kolda and
Procopio. Trust is binary, and we reproduce the results in Figure 1/Table 2 and Figure 2/Table 3.

The qthreads portion of mtgl/badrank.hpp has not been updated, and so is still incorrect. In addition, some new loops got introduced in the recent edits. These will have to be qthreaded/XMT profiled. I will attach two regression tests to this ticket:

./test_badrank kp_figure1.dimacs 1 0 0.0001
…..


Top 5 bad ranks:


0.345723
0.305426
0.143316
0.143316
0.062220

./test_badrank kp_figure2.dimacs 2 1 0.0001
……


Top 10 bad ranks:


0.281190
0.281190
0.147548
0.079740
0.002680
0.001000
0.001000
0.001000
0.001000
0.203653

Attachments

kp_figure1.dimacs Download (81 bytes) - added by jberry 6 years ago.
kp_figure2.dimacs Download (109 bytes) - added by jberry 6 years ago.

Change History

Changed 6 years ago by jberry

Changed 6 years ago by jberry

comment:1 Changed 6 years ago by gemacke

  • Owner set to gemacke
  • Status changed from new to accepted

comment:2 Changed 6 years ago by gemacke

  • Status changed from accepted to closed
  • Resolution set to fixed

This was addressed in 3853. This ticket is almost a duplicate of #4130, but it adds test cases. I have tested the parallelized XMT and Qthreads badrank against the test cases, and they pass.

comment:3 Changed 6 years ago by gemacke

Oops. Meant to say it was addressed in r3853.

Note: See TracTickets for help on using tickets.