Ticket #3976 (closed enhancement: duplicate)

Opened 8 years ago

Last modified 6 years ago

Get rid of compressed_sparse_row_graph::operator[]

Reported by: gemacke Owned by: jberry
Priority: low Milestone: 1.2
Version: 1.0 Severity: normal
Keywords: Cc: gemacke

Description

Really this ticket is about getting rid of where the [] operator is used. Removing it from compressed_sparse_row_graph is trivial. One place that the operator is used is in mtgl/pagerank.hpp. It may be used in other places, and anywhere it is used should be changed to using the normal MTGL interface.

Part of this is determining if the standard interface will behave just as well as the operator[] in situations where it is used. My guess is that it will due to many improvements made since this operator was first introduced. If not, maybe we should keep it or do some more work to improve things.

Change History

comment:1 Changed 8 years ago by gemacke

  • Cc gemacke added
  • Owner changed from gemacke to jberry
  • Status changed from new to assigned

Jon, since the pagerank code is one of yours, would you look into this when you get a chance? Also, do you know if this operator is used anywhere else in the MTGL codebase?

comment:2 Changed 8 years ago by gemacke

  • Priority changed from normal to low
  • Type changed from defect to enhancement

comment:3 Changed 7 years ago by gemacke

  • component Eldorado deleted

comment:4 Changed 6 years ago by gemacke

  • Version set to 1.0

comment:5 Changed 6 years ago by gemacke

  • Milestone set to 1.2

comment:6 Changed 6 years ago by gemacke

  • Status changed from assigned to closed
  • Resolution set to duplicate

Duplicate of #4048, which is already fixed.

Note: See TracTickets for help on using tickets.