Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Ticket #3917 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

gcovr not creating the source tags correctly

Reported by: anonymous Owned by: jdsiiro
Priority: normal Milestone: FAST 2.2
Component: gcovr Version:
Keywords: Cc:

Description

this seems to be related to the issue here: https://software.sandia.gov/trac/fast/ticket/3869

I am calling gcovr as follows
./thirdparty/gcovr/gcovr-2.3.1/scripts/gcovr -x --root "" -e ".*/thirdparty/+|.*/test/+" > ./build/products/company/company_coverage.xml

The filename in the coverage.xml is as follows:
filename="build/macosx/../../product/Source/Classes/TestClass.cpp"

The <source> tag is left blank

From reading issue #3869 it seems like the filename should not show the path, and the <source> tag should have the full path name

I am trying to use this with hudson, and hudson cannot find the source file.

Attachments

Change History

comment:1 Changed 2 years ago by jdsiiro

Referenced in changeset [2753]:

Checking that the --root is not empty: this is a meaningless value (as the root option should point to a directory) that leads to a poorly-formatted XML report (see #3917).

comment:2 Changed 2 years ago by jdsiiro

  • Status changed from new to closed
  • Resolution set to fixed

There are two issues here:

  • the --root option was specifying an empty string (which we are now checking for; see [2753])
  • the filename contains relative path elements (which is a duplicate of #3921)

Given that [2753] should "fix" the generation of the source tag in the XML (by disallowing an empty root string), I am closing this as fixed.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.