Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Ticket #3881 (closed defect: duplicate)

Opened 8 years ago

Last modified 8 years ago

gcovr issue with gcov output

Reported by: wehart Owned by: jdsiiro
Priority: normal Milestone:
Component: gcovr Version:
Keywords: Cc: jan.ruzicka@…

Description

Thanks for the gcovr script.
I was trying to use it, but I was getting only empty output.

Stepping around the script in debugger was showing that lines (creating `foo')[2] were not matching specified regular expression.
I'm not sure if it's because the gcov used is too old [1] 3.4.6 or some other reason.

Attached patch fixes the issue and the output shows some contents.
I wasn't able to confirm that the output is correct, but I hope to have it working on our hudson setup tomorrow.

Sincerely
Jan Ruzicka

[1]
$ gcov -v
gcov (GCC) 3.4.6 20060404 (Red Hat 3.4.6-11) Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

[2]
$ gcov --branch-counts --branch-probabilities --preserve-paths tea File `tea.c'
Lines executed:0.00% of 36
Branches executed:0.00% of 8
Taken at least once:0.00% of 8
Calls executed:0.00% of 8
tea.c:creating `tea.c.gcov'

Attachments

gcovr.patch Download (387 bytes) - added by wehart 8 years ago.

Change History

Changed 8 years ago by wehart

comment:1 Changed 8 years ago by jdsiiro

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3878

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.