Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Ticket #3811 (closed task: fixed)

Opened 10 years ago

Last modified 10 years ago

Generate XML output in Cobertura format

Reported by: wehart Owned by: wehart
Priority: minor Milestone:
Component: gcovr Version:
Keywords: Cc:

Attachments

Change History

comment:1 Changed 10 years ago by jdsiiro

I am not going to argue against this feature, but are you adding it solely to get coverage reports within Hudson builds? The Hudson Cobertura plugin has been been deprecated and is no longer supported. It will be replaced in the near future by a coverage plugin that has native support for gcov (see  here).

comment:2 Changed 10 years ago by wehart

  • Priority changed from major to minor

John's correct that this ticket was intended to support Hudson. I'm downgrading the priority of this, but I'm leaving this in Trac until we confirm that this other plugin is going to work.

comment:3 Changed 10 years ago by wehart

  • Milestone FAST 2.1 deleted

comment:4 Changed 10 years ago by jdsiiro

  • Status changed from new to closed
  • Resolution set to fixed

r2013 - r2016 add this functionality, enabled with the -x, --xml option.

The Cobertura plugin has been installed on Hudson.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.