Ticket #4246 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Compilation problem on fedora 17

Reported by: ycollette.nospam@… Owned by: briadam
Priority: normal Milestone: 5.3
Component: Code Errors/Issues Version: VOTD
Severity: normal Keywords:
Cc: briadam, wjbohnh Due Date:
Parent Tickets: Blocked By:
Blocking: Requestor:
Sensitive: no

Description

Hello,

I am on fedora 17 64 bits.
The gcc version is: 4.7.2

When building dakota, I met a compilation error:

[ 69%] Building CXX object src/CMakeFiles/dakota_src.dir/ParallelLibrary.cpp.o
In file included from /home/collette/repositories/dakota/src/ResultsManager.hpp:19:0,

from /home/collette/repositories/dakota/src/ParallelLibrary.cpp:20:

/home/collette/repositories/dakota/src/ResultsDBAny.hpp: In member function ‘StoredType? Dakota::ResultsDBAny::get_data(const StrStrSizet?&, const string&) const’:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:204:76: erreur: no matching function for call to ‘Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) const’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:204:76: note: candidate is:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: const ResultsValueType?& Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) <near match>
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: no known conversion for implicit ‘this’ parameter from ‘const Dakota::ResultsDBAny*’ to ‘Dakota::ResultsDBAny*’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp: In member function ‘StoredType? Dakota::ResultsDBAny::get_array_data(const StrStrSizet?&, const string&, size_t) const’:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:216:76: erreur: no matching function for call to ‘Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) const’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:216:76: note: candidate is:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: const ResultsValueType?& Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) <near match>
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: no known conversion for implicit ‘this’ parameter from ‘const Dakota::ResultsDBAny*’ to ‘Dakota::ResultsDBAny*’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp: In member function ‘const StoredType?* Dakota::ResultsDBAny::get_data_ptr(const StrStrSizet?&, const string&) const’:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:231:76: erreur: no matching function for call to ‘Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) const’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:231:76: note: candidate is:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: const ResultsValueType?& Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) <near match>
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: no known conversion for implicit ‘this’ parameter from ‘const Dakota::ResultsDBAny*’ to ‘Dakota::ResultsDBAny*’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp: In member function ‘const StoredType?* Dakota::ResultsDBAny::get_array_data_ptr(const StrStrSizet?&, const string&, size_t) const’:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:243:76: erreur: no matching function for call to ‘Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) const’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:243:76: note: candidate is:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: const ResultsValueType?& Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) <near match>
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: no known conversion for implicit ‘this’ parameter from ‘const Dakota::ResultsDBAny*’ to ‘Dakota::ResultsDBAny*’
make[2]: * [src/CMakeFiles/dakota_src.dir/ParallelLibrary.cpp.o] Erreur 1
make[1]:
* [src/CMakeFiles/dakota_src.dir/all] Erreur 2

Best regards,

YC

Subtickets

Change History

comment:1 Changed 6 years ago by briadam

  • Cc briadam, wjbohnh added
  • Status changed from new to accepted

Hi Yann -- Thanks for catching this. There is definitely a const correctness issue there. I think this patch will fix, but am still testing. Could you please post your compiler flags? I am concerned that your (newer) compiler caught it, but mine didn't. I am installing gcc-4.7.2 now to verify. -- Brian

Index: ResultsDBAny.hpp
===================================================================
--- ResultsDBAny.hpp	(revision 1517)
+++ ResultsDBAny.hpp	(working copy)
@@ -105,7 +105,7 @@
 
   /// attempt to find the requested data, erroring if not found
   const ResultsValueType& lookup_data(const StrStrSizet& iterator_id,
-				      const std::string& data_name);
+				      const std::string& data_name) const;
 
   /// cast the reference to the any data to the requested type
   template<typename StoredType>
Index: ResultsDBAny.cpp
===================================================================
--- ResultsDBAny.cpp	(revision 1517)
+++ ResultsDBAny.cpp	(working copy)
@@ -59,7 +59,7 @@
 
 const ResultsValueType& 
 ResultsDBAny::lookup_data(const StrStrSizet& iterator_id,
-			  const std::string& data_name)
+			  const std::string& data_name) const
 {
   ResultsKeyType key = make_key(iterator_id, data_name);

comment:2 Changed 6 years ago by briadam

Referenced in changeset [1520]:

Resolve Ticket #4246, compilation problem on gcc-4.7.2 due to const correctness. I was able to reproduce on my system with gcc-4.7.2 and confirmed that this changes fixes.

comment:3 Changed 6 years ago by ycollette.nospam@…

Hello,

Here is the result of make VERBOSE=1:

[ 70%] Building CXX object src/CMakeFiles/dakota_src.dir/ParallelLibrary.cpp.o
cd /home/collette/repositories/dakota/build/src && /usr/bin/c++ -Ddakota_src_EXPORTS -DHAVE_CONFIG_H -DHAVE_CONFIG_H -DDISABLE_DAKOTA_CONFIG_H -DBOOST_MULTI_INDEX_DISABLE_SERIALIZATION -DDAKOTA_PLUGIN -DBOOST_DISABLE_ASSERTS -DDAKOTA_HAVE_BOOST_FS -DHAVE_UNISTD_H -DHAVE_SYSTEM -DHAVE_WORKING_FORK -DHAVE_WORKING_VFORK -DHAVE_SYS_WAIT_H -DHAVE_USLEEP -DDAKOTA_F90 -DHAVE_PECOS -DHAVE_SURFPACK -DDAKOTA_COLINY -DDAKOTA_UTILIB -DHAVE_ADAPTIVE_SAMPLING -DHAVE_CONMIN -DDAKOTA_DDACE -DHAVE_FSUDACE -DDAKOTA_HOPS -DHAVE_JEGA -DHAVE_NCSU -DHAVE_NL2SOL -DHAVE_OPTPP -DDAKOTA_OPTPP -DHAVE_PSUADE -DHAVE_AMPL -fPIC -I/home/collette/repositories/dakota/build -I/home/collette/repositories/dakota/build/src -I/home/collette/repositories/dakota/src -I/home/collette/repositories/dakota/packages -I/home/collette/repositories/dakota/build/packages/teuchos -I/home/collette/repositories/dakota/build/packages/teuchos/. -I/home/collette/repositories/dakota/build/packages/teuchos/packages/teuchos/src -I/home/collette/repositories/dakota/packages/teuchos/packages/teuchos/src -I/home/collette/repositories/dakota/build/packages/pecos -I/home/collette/repositories/dakota/packages/pecos/src -I/home/collette/repositories/dakota/packages/pecos/packages/VPISparseGrid/src -I/home/collette/repositories/dakota/build/packages/surfpack -I/home/collette/repositories/dakota/packages/surfpack/src -I/home/collette/repositories/dakota/build/packages/acro/packages -I/home/collette/repositories/dakota/build/packages/acro/packages/utilib -I/home/collette/repositories/dakota/packages/acro/packages/interfaces/src -I/home/collette/repositories/dakota/packages/acro/packages/scolib/src -I/home/collette/repositories/dakota/packages/acro/packages/utilib/src -I/home/collette/repositories/dakota/packages/acro/packages/colin/src -I/home/collette/repositories/dakota/packages/acro/tpl/tinyxml -I/home/collette/repositories/dakota/build/packages/DDACE -I/home/collette/repositories/dakota/packages/DDACE/include -I/home/collette/repositories/dakota/build/packages/FSUDace -I/home/collette/repositories/dakota/packages/FSUDace -I/home/collette/repositories/dakota/build/packages/hopspack/src/src-shared -I/home/collette/repositories/dakota/packages/hopspack/src/src-shared -I/home/collette/repositories/dakota/packages/hopspack/src/src-citizens -I/home/collette/repositories/dakota/packages/hopspack/src/src-evaluator -I/home/collette/repositories/dakota/packages/hopspack/src/src-executor -I/home/collette/repositories/dakota/packages/hopspack/src/src-framework -I/home/collette/repositories/dakota/packages/hopspack/src/src-main -I/home/collette/repositories/dakota/build/packages/JEGA -I/home/collette/repositories/dakota/build/packages/JEGA/eddy -I/home/collette/repositories/dakota/packages/JEGA/eddy -I/home/collette/repositories/dakota/packages/JEGA/include -I/home/collette/repositories/dakota/build/packages/NP2SOL -I/home/collette/repositories/dakota/build/packages/OPTPP/include -I/home/collette/repositories/dakota/packages/OPTPP/include -I/home/collette/repositories/dakota/packages/PSUADE -I/home/collette/repositories/dakota/build/packages/ampl -DHAVE_RPC_XDR_H -DHAVE_RPC_TYPES_H -o CMakeFiles/dakota_src.dir/ParallelLibrary.cpp.o -c /home/collette/repositories/dakota/src/ParallelLibrary.cpp
In file included from /home/collette/repositories/dakota/src/ResultsManager.hpp:19:0,

from /home/collette/repositories/dakota/src/ParallelLibrary.cpp:20:

/home/collette/repositories/dakota/src/ResultsDBAny.hpp: In member function ‘StoredType? Dakota::ResultsDBAny::get_data(const StrStrSizet?&, const string&) const’:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:204:76: erreur: no matching function for call to ‘Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) const’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:204:76: note: candidate is:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: const ResultsValueType?& Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) <near match>
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: no known conversion for implicit ‘this’ parameter from ‘const Dakota::ResultsDBAny*’ to ‘Dakota::ResultsDBAny*’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp: In member function ‘StoredType? Dakota::ResultsDBAny::get_array_data(const StrStrSizet?&, const string&, size_t) const’:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:216:76: erreur: no matching function for call to ‘Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) const’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:216:76: note: candidate is:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: const ResultsValueType?& Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) <near match>
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: no known conversion for implicit ‘this’ parameter from ‘const Dakota::ResultsDBAny*’ to ‘Dakota::ResultsDBAny*’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp: In member function ‘const StoredType?* Dakota::ResultsDBAny::get_data_ptr(const StrStrSizet?&, const string&) const’:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:231:76: erreur: no matching function for call to ‘Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) const’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:231:76: note: candidate is:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: const ResultsValueType?& Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) <near match>
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: no known conversion for implicit ‘this’ parameter from ‘const Dakota::ResultsDBAny*’ to ‘Dakota::ResultsDBAny*’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp: In member function ‘const StoredType?* Dakota::ResultsDBAny::get_array_data_ptr(const StrStrSizet?&, const string&, size_t) const’:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:243:76: erreur: no matching function for call to ‘Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) const’
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:243:76: note: candidate is:
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: const ResultsValueType?& Dakota::ResultsDBAny::lookup_data(const StrStrSizet?&, const string&) <near match>
/home/collette/repositories/dakota/src/ResultsDBAny.hpp:107:27: note: no known conversion for implicit ‘this’ parameter from ‘const Dakota::ResultsDBAny*’ to ‘Dakota::ResultsDBAny*’
make[2]: * [src/CMakeFiles/dakota_src.dir/ParallelLibrary.cpp.o] Erreur 1
make[2] : on quitte le répertoire « /home/collette/repositories/dakota/build »
make[1]:
* [src/CMakeFiles/dakota_src.dir/all] Erreur 2
make[1] : on quitte le répertoire « /home/collette/repositories/dakota/build »

Best regards,

YC

comment:4 Changed 6 years ago by briadam

  • Status changed from accepted to closed
  • Resolution set to fixed

Thanks again Yann. I was able to reproduce on gcc-4.7.2 and believe with my commit it is corrected. If you SVN update, should be resolved. -- B

comment:5 Changed 6 years ago by briadam

Referenced in changeset [1540]:

Merged revisions 1493-1511,1513-1538 via svnmerge from  https://software.sandia.gov/svn/public/dakota/core/trunk

........

r1493 | wjbohnh | 2013-01-31 14:44:13 -0700 (Thu, 31 Jan 2013) | 6 lines

Added timeout overrides for these new tests consistent with other moga tests.

Request review by Brian Adams and/or Ken Hu.

........

r1494 | dmvigi | 2013-01-31 16:57:56 -0700 (Thu, 31 Jan 2013) | 1 line

minor fixes to INSTALL

........

r1495 | dmvigi | 2013-01-31 17:17:28 -0700 (Thu, 31 Jan 2013) | 1 line

fixed bug in ldd path; now sets path correctly for manual 'make package' and Jenkins CPack packaging

........

r1496 | pdhough | 2013-02-01 15:01:13 -0700 (Fri, 01 Feb 2013) | 6 lines

Changing interface to "direct". Slow redsky file system was creating issues in the nightlies with the "fork" interface. No update to baseline needed.

........

r1497 | wjbohnh | 2013-02-01 16:46:25 -0700 (Fri, 01 Feb 2013) | 5 lines

Yet another attempt to get packaging of non-system .so's correct with dakota.

Request review by Dena Vigil.

........

r1498 | wjbohnh | 2013-02-01 17:08:57 -0700 (Fri, 01 Feb 2013) | 4 lines

Yet another attempt to get packaging of non-system dynamic libs is correct with dakota. Mac and Cygwin cases are now consistent with UNIX (previous commit).

........

r1499 | wjbohnh | 2013-02-02 21:50:44 -0700 (Sat, 02 Feb 2013) | 5 lines

Changing interface to "direct". Slow glory file system was creating issues in the nightlies with the "fork" interface. No update to baseline needed.

........

r1500 | wjbohnh | 2013-02-02 21:55:24 -0700 (Sat, 02 Feb 2013) | 6 lines

Bump the time override parameter a bit to see if the test will pass on TLCC tonight. Manual run on taco indicates this test runs fine, to completion, so this does NOT work, probably carry this "timeout" for the release and note it in the 5.3 release artifacts.

........

r1501 | wjbohnh | 2013-02-03 23:57:36 -0700 (Sun, 03 Feb 2013) | 4 lines

Minor revision indicating that a Cygwin (no MinGW) emulation layer is supported for customers on Windows platforms.

........

r1502 | briadam | 2013-02-04 17:47:59 -0700 (Mon, 04 Feb 2013) | 1 line

Update some Jaguar GUI groups to sync with ref manual and in response to some deployment testing issues.

........

r1503 | mseldre | 2013-02-04 18:22:39 -0700 (Mon, 04 Feb 2013) | 3 lines

Add examples used in Advanced Topics training. TO DO: do these need to be hooked into build harness for "make install" ?

........

r1504 | mseldre | 2013-02-04 18:39:39 -0700 (Mon, 04 Feb 2013) | 2 lines

Some cleanup to Dev Manual main page.

........

r1505 | mseldre | 2013-02-04 19:39:00 -0700 (Mon, 04 Feb 2013) | 3 lines

Updates to local reliability chapter, capturing the updated equality constraint formulation for second-order PMA.

........

r1506 | wjbohnh | 2013-02-05 08:43:32 -0700 (Tue, 05 Feb 2013) | 4 lines

Bump TD timeout override for test #1 a bit to ensure achieve stable test (no stale output failure) on TLCC (glory/taco).

........

r1507 | briadam | 2013-02-05 09:13:07 -0700 (Tue, 05 Feb 2013) | 1 line

Set LC_ALL on Cygwin so dakota.sh works from within a Cygwin shell.

........

r1508 | briadam | 2013-02-05 11:30:31 -0700 (Tue, 05 Feb 2013) | 1 line

Adjust generic example to work properly on Windows, both in Cygwin and Command Prompt

........

r1509 | briadam | 2013-02-05 12:57:48 -0700 (Tue, 05 Feb 2013) | 1 line

Since prepending/appending PATH on Windows doesn't just affect the .bat file, but instead the environment of the calling command prompt, need to protect prepend so doesn't happen multiple times. Also correct some issues with quoting and addition of lib dirs in dakota.bat.

........

r1510 | briadam | 2013-02-05 13:04:13 -0700 (Tue, 05 Feb 2013) | 1 line

Install dakota.bat on both MSVC and CYGWIN. Will be useful for running at command prompt. Continue to install dakota.sh for non-MSVC builds

........

r1511 | mseldre | 2013-02-05 13:44:42 -0700 (Tue, 05 Feb 2013) | 16 lines

Some edits to existing tests to annotate them for export to examples/advanced. I had to add one test to dakota_uq_cantilever_adapt_gsg.in to support desired consistency with PCBDO cantilever results. I will check in its new baseline separately so that it can be kept off of the release branch (to avoid any affect of this new test on the test artifacts).

The mapping to examples/advanced is as follows:

dakota_dace.in #0 dakota_hybrid.in #0 (Note: replaces dakota_textbook_hybrid.in) dakota_uq_cantilever_ivp_exp.in #4 dakota_sbo_hierarchical #0 dakota_pcbdo_cantilever.in #4 dakota_uq_cantilever_adapt_gsg.in #8 (Note: new test, no baseline for v5.3)

Merge this commit to the release branch.

........

r1513 | briadam | 2013-02-05 14:38:39 -0700 (Tue, 05 Feb 2013) | 1 line

Minor updates to user's to track moving generic/simulator_script from csh to sh.

........

r1514 | wjbohnh | 2013-02-05 15:33:50 -0700 (Tue, 05 Feb 2013) | 15 lines

Implemented a workaround for otool and Boost .dylib files. For some reason Boost seems to be a "special case" (at least on ictinus) and otool does NOT provide the absolute path to the libboost_*.dylib files.

So the CMakeCache.txt is probed and the full path to boost libs is used during the install/packaging step.

I'm not very enthusiastic about this approach, and will consider better ways to create the deployment tarballs on Mac AFTER the release.

Request review by Brian and/or Dena.

Trac ticket #4058.

........

r1515 | wjbohnh | 2013-02-05 16:21:31 -0700 (Tue, 05 Feb 2013) | 3 lines

Removed legacy autotools INSTALL example files.

........

r1516 | wjbohnh | 2013-02-05 16:46:47 -0700 (Tue, 05 Feb 2013) | 6 lines

Moved INSTALL.cygwin into to the cygwin_demo directory.

Removed INSTALL.osx since the legacy, autotools tips have been supplanted by the wiki, e.g.  http://software.sandia.gov/trac/dakota/wiki/PlatformSpecificSetup#MacOSXLeopard10.5.8DarwinKernelVersion9.8.0

........

r1517 | wjbohnh | 2013-02-05 16:52:57 -0700 (Tue, 05 Feb 2013) | 4 lines

Updated the README to be consistent with the files contained in this directory. There is no longer any mention of autotools or 'configure' scripts in the file.

........

r1518 | briadam | 2013-02-05 17:06:29 -0700 (Tue, 05 Feb 2013) | 1 line

Add build and install commands for Mike's extracted examples for advanced training. Renamed some to be consistent with new User's manual naming. Also some cleanup in cantilever since the saved files don't conform and are outdated.

........

r1519 | wjbohnh | 2013-02-06 11:40:36 -0700 (Wed, 06 Feb 2013) | 4 lines

Provide an example CTest script resulting from the CMake/CTest/CDash work with Zack Galbreath at Kitware.

........

r1520 | briadam | 2013-02-06 12:26:47 -0700 (Wed, 06 Feb 2013) | 1 line

Resolve Ticket #4246, compilation problem on gcc-4.7.2 due to const correctness. I was able to reproduce on my system with gcc-4.7.2 and confirmed that this changes fixes.

........

r1521 | mseldre | 2013-02-06 15:52:22 -0700 (Wed, 06 Feb 2013) | 4 lines

Progress on Theory Manual updates:

finalize local reliability updates. update PCE regression docs that preceded John's new CS descriptions.

........

r1522 | mseldre | 2013-02-06 16:44:01 -0700 (Wed, 06 Feb 2013) | 2 lines

Refinements to CS descriptions following review with John.

........

r1523 | mseldre | 2013-02-06 18:54:06 -0700 (Wed, 06 Feb 2013) | 5 lines

Reorganize Theory Manual description of interpolation polynomials to include 1D hierarchical interpolants.

TO DO: build towards multivariate hierarchical interpolation on sparse grids.

........

r1524 | briadam | 2013-02-07 10:25:07 -0700 (Thu, 07 Feb 2013) | 1 line

Change to .zip packaging on Cygwin. Still only binary as we don't need to generate source archives on this platform. Also fix issue with Cygwin DLL packaging by using PWD instead of CD. Works in my local build.

........

r1525 | mseldre | 2013-02-07 18:34:55 -0700 (Thu, 07 Feb 2013) | 2 lines

Finish hierarchical SC additions to Theory Manual.

........

r1526 | mseldre | 2013-02-07 18:53:05 -0700 (Thu, 07 Feb 2013) | 5 lines

Clean up several broken links in Table 2.1. I suspect there may be other broken links as the Cmake build log is suppressing these messages.

Request review by Laura.

........

r1527 | mseldre | 2013-02-07 19:32:09 -0700 (Thu, 07 Feb 2013) | 3 lines

Finish cleaning out references to all_variables. Also removed the Variable views table from the Responses chapter, as it was duplicative.

........

r1528 | wjbohnh | 2013-02-07 22:40:27 -0700 (Thu, 07 Feb 2013) | 3 lines

Comment-out Boost spec since specific to ictinus.

........

r1529 | mseldre | 2013-02-07 22:45:09 -0700 (Thu, 07 Feb 2013) | 9 lines

My pass through the UQ chapter. Would benefit from additional consolidation (method descriptions in Usage Guidelines seem repetitive), reorganization (more advanced examples precede the simple examples relocated from Chapter 2), and figure management (need to force figure pages to prevent too many figures from being delayed well after their associated text), but these matters will have to wait.

Done with manual edits for v5.3.

........

r1530 | briadam | 2013-02-08 08:39:00 -0700 (Fri, 08 Feb 2013) | 1 line

Change Mac CR-only format to Unix LF only format to address Windows build problem.

........

r1531 | briadam | 2013-02-08 15:08:30 -0700 (Fri, 08 Feb 2013) | 1 line

Make dynamic library packaging tolerant of symbolic links in the path to the build tree. Was a problem on mac build, where the BINARY_DIR path traversed a symlink and didn't filter out the build tree .dylibs.

........

r1532 | mseldre | 2013-02-08 15:46:22 -0700 (Fri, 08 Feb 2013) | 14 lines

Bug fix for ticket #3307, reported by Rich Drake. The DVV for the numerical integration sampler was being set to the DVV from the finalStatistics object in the default case of no derivative usage. Outside of a nested iteration context, this finalStatistics DVV is empty, causing a smaller MPI packed buffer than expected (not normally an error, but Rich found that it caused problems on Cielo). The patch was to alter the default DVV behavior for the case where a finalStatistics DVV has not been defined.

Note: Rich's buffer padding function would make this more robust in general, as there still are cases where the buffer size estimation involves a worst case DVV length. But this is intended as a minimal change patch for v5.3.

Merge to release branch.

........

r1533 | mseldre | 2013-02-08 16:02:58 -0700 (Fri, 08 Feb 2013) | 2 lines

Refinement to the final_dvv assignment logic. Merge to branch.

........

r1534 | mseldre | 2013-02-08 20:08:40 -0700 (Fri, 08 Feb 2013) | 9 lines

Resolve a few issues in Users Manual:

remove section on additional UQ examples by pushing these examples into

corresponding sections of chapter. Now, simple examples precede the more advanced examples.

enforce [htbp!] on figures in UQ chapter to promote early insertion resolve all broken cross references

TO DO: fold in redundant method descriptions from UQ Usage Guidelines.

........

r1535 | mseldre | 2013-02-08 21:26:16 -0700 (Fri, 08 Feb 2013) | 2 lines

Some rework to UQ usage guidelines. Done with Users Manual changes.

........

r1536 | pdhough | 2013-02-09 16:55:16 -0700 (Sat, 09 Feb 2013) | 5 lines

Added strategy block to the hybrid example.

........

r1537 | lpswile | 2013-02-10 10:01:12 -0700 (Sun, 10 Feb 2013) | 3 lines

Minor changes/cleanup to Tutorial Chapter.

........

r1538 | wjbohnh | 2013-02-10 12:45:51 -0700 (Sun, 10 Feb 2013) | 6 lines

Build the Dakota documentation package if ENABLE_DAKOTA_DOCS is ON. Trac ticket #4058.

Request review by Dena Vigil.

........

Note: See TracTickets for help on using tickets.