Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Ticket #3035 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

compile error in PicoLPSubclass.h

Reported by: lafisk Owned by: pico-developers
Priority: major Milestone:
Component: PICO Version: Beta
Keywords: Cc: lafisk, caphill
Subcomponent: Source Code

Description (last modified by wehart) (diff)

What configuration options were you using for this build?

I'm having some difficulty building on sadl14088 because f77 doesn't appear to be on that machine, but COIN needs it.

Attachments

Change History

comment:1 Changed 7 years ago by lafisk

Search for "Compile error" in pico/src/lp/pico/PicoLPSubclass.h.
I added a comment twice in this header identifying the two lines
that get compile errors on sadl14088.

Here's one:
../../../include/pico/PicoLPSubclass.h:786: error: cannot call member function

`virtual int OsiSolverInterface::getNumCols() const' without object

This seems to compile successfully on most other Linux machines. I'm
not sure what the problem is.

comment:2 Changed 7 years ago by wehart

What configuration options were you using for this build?

I'm having some difficulty building on sadl14088 because f77 doesn't appear to be on that machine, but COIN needs it.

comment:3 Changed 6 years ago by wehart

  • Cc lafisk, caphill added
  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

I'm going to treat this as fixed, since we've been building PICO for the past few years without problems...

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.